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Help Menu 

The Help Menu is now standardized throughout all desktops and modules and includes three 

menu options: Help Topics, Support Online, and Help About. 

Help Topics 

All of the latest documentation is now available by using the Help Topics option on the Help 

menu or the Help button at the bottom of the Tasks pane.  

Selecting the Help Topics option displays the Help Viewer.  

Help documents can be accessed via the three tabs that are available on the left side of the 

screen and are easily viewed in the display area on the right. 

The Contents tab displays a preloaded list of reference documents when the Help Viewer is 

first selected. Contents displays a list of the documents in a three level tree view organized 

first by document, chapters within the document, and then by sections in each chapter. The 

document and chapter levels contain descriptions about the particular document or chapter. 

Articles can be selected at the section level. Once an article in the section level is selected, it 

can be read in the display area. 

The Index tab displays an alphabetic list of contexts. Once an article in the list is selected, it 

can be read in the display area. 

The Search tab article results are blank when the Help Viewer is first opened. To search 

articles, enter the desired phrase or text in the search box and select the Go button. All articles 

containing the phrase in the heading or article contents will be returned to the Search pane in 

list format. Once an article in the list is selected, it can be read in the display area. 

When an article under any of the tabs is selected, it is displayed in the right hand area of the 

screen. The article will remain in the display area until a new article is selected. Switching 

tabs will continue to display that same article until a new search is performed or another 

article is selected. 

Support Online 

This option allows you to connect to the People-Trak customer support website. On the 

support website, you can download patches, review newsletters, provide feedback, and 

communicate with your Support Representative.  

Help About 

This option displays your People-Trak license and options information.  
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Categories 

Within People-Trak, Workflows, Activities, Processes, Tables, Screens, Fields and 

Documents all have a category assigned to them. These categories can be secured within 

Security Setup –Module and are organized within the Categories pane on the Desktop. This 

category centric approach also extends into each of the modules as fields, screens, 

documents, notes, tables, and help are now accessible by category when in an open record.  

Category Help 

The Category Help feature allows you to view help text for all screens, tables, documents, 

templates, derived fields, processing, triggers, activities and workflows within the current 

category. 

Category Help is made up of two different components: the category tree located in the pane 

on the left and the help text display area on the right.  The category tree utilizes a tree-view 

control for the usage areas and their related items. Usage areas are listed on the first level and 

each usage item is listed by name at the second level. If a usage area does not show up as 

header, it is due to the fact that the category does not have any usage in that area. Listed 

below are the usage areas that may be found within a category: 

 Activities 

 Derived Fields 

 Documents 

 Processing 

 Screens 

 Tables 

 Table Maps-Incoming 

 Table Maps-Outgoing 

 Templates 

 Triggers 

 Workflows 

 

Field Help  

Field help is available at any field and can be activated by using the F1 key or the Show Field 

Help button on the Tool Bar.  

Field Help Features 
Field Help provides an Overview of the selected field when it is first launched.  

The left pane of the Field Help screen utilizes a tree-view control for usage areas at the first 

level and their related usage items at the second level. If a usage area does not show up as 

header, it is due to the fact that the field is not used in that area. Listed below are the usage 

areas a field may be found in: 

 Alert Conditions 

 Alert Triggers 

 Field Triggers 

 Field Triggers-Update 

 Record Save Triggers 

 Trigger Query 
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 Database Manager 

 Document Query 

 Import Specifications 

 Report Definitions 

 Derived Fields 

 Screens 

 Table Maps-Incoming 

 Table Maps-Outgoing 

 Templates 

 

If you would like to view the help for a specific usage item, simply select that item in the list 

and the help text will show up in the display area to the right. 

 

The Properties and Attributes provide additional details for the selected field. They are listed 

and described below. 

Field ID The Field ID is the database field identifier for this field.  

Table Name The Table Name shows the name of the table in which the current field belongs. 

Field Name The Field Name is the name used to uniquely identify the field. 

Category The Category is the pre-defined category within the module to which this field is associated. 

Screen Caption The Screen Caption is the phrase that is displayed adjacent to a text box or check box, or in 

the header of a grid. 

Field Length The Field Length field is the number of characters that can be entered into the current field. 

Field Type The Field Type field indicates the type of the field. 

Edit Attributes The Edit Attributes field is used to either format or validate the entry. The edit attributes that 

are available are determined by the Field Type 

Popup Type The Popup Type field indicates the type of popup (if any) that is used to support data entry in 

the field. 

Support Table The Support Table field indicates the support table (if any) that is used to support data entry 

in the field. 

Audit The Audit check box is used specify if the field is auditable or not. 

Display Only The Display Only check box is used to set the field to display only. 
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Fixed Display 

Only 

The Fixed Display Only check box is selected if the field is a People-Trak fixed display only 

field or cleared if not. 

Not Used The Not Used check box is used to cause the field not to be used. 

Required The Required check box is used to set the field to required. 

Encrypted The Encrypted check box is used to specify that the field be encrypted when saved to the 

database. 

Masked Text The Masked Text check box is used to specify if the text in the field is masked when 

displayed. 

Screen Help 

Screen help is available at any screen and can be activated by using the SHIFT + F1 key 

sequence or the Show Screen Help button on the Tool Bar. If the screen does not have a 

Show Screen Help button, the key sequence will display Screen Help. When this option is 

used, the Screen Help screen is displayed. 

Screen Help Features 
Field Help provides an Overview of the selected field when it is first launched. Depending on 

the complexity of the screen, the overview may be organized into a single article or a two 

level tree view by topic and then article. 

The left pane of the Screen Help screen utilizes a tree-view control for usage areas at the first 

level and their related usage items at the second level. If a usage area does not show up as 

header, it is due to the fact that the screen is not used in that area. Listed below are the usage 

areas a screen may be found in: 

 Triggers-Display Screen 

 Workflows 

 

In addition to usage, screen help includes a list of screen objects in a three level tree view 

organized first by tabs (when applicable), second by frames and/or grids, and then by fields 

within the frame or grid. The tab and field levels contain help text relevant to the tab or field. 

Introduction to the Help Editor 

The Help Editor is a powerful word processing tool that emulates many of the features in 

Microsoft Word. It is used for editing help text for the following: 

  Adhoc Reports 

 Cluster Reports 

 Email  

 Forms 

 Export 

 Freeform Reports 

 Labels 

 Letters 
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 Lookup Favorites 

 Standard Reports 

 Email Templates 

 Label Templates 

 Form Templates 

 Letter Templates 

 Alert Triggers 

 Schedule Triggers 

 System Templates 

 Import 

 Database Manager 

 Fields within Field Customization 

 Screens  

 Help Topics 

 

With the implementation of the Strategic Toolkit, it is additionally used for editing help 

text for the following: 

 

 Custom Screens 

 Workflows 

 Derived Fields 

 Button Triggers 

 Field Change Triggers 

 Record Save Triggers 

 

Help may be edited anywhere Help is found. Use the Edit button to display the Help Editor 

screen and edit the help text.  

Note: The ability to edit help can be turned off for a user by clearing the Allow Help Edit 

check box in Security Setup. 

Help Editor Menu Bar 

The Menu Bar is displayed at the top of the editor form and functions like other menus in 

People-Trak. It contains a phrase for each of the Editor menus. When the mouse is clicked on 

one of these phrases, the corresponding menu is displayed. Each of the menus listed on the 

Menu Bar is described in detail below. 

File Menu 

Save Saves any changes to the help text and stays in the Help Editor. 

Exit Allows you to exit the editor and return to the screen from which the editor was started. If 

changes have been made to the help text, the changes are saved. 

Edit Menu 

Undo Allows you to undo the latest change. If more than one change has been done, you can 

undo them one at a time. The Undo function is also available as a button on the Tool Bar. 
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Redo Allows you to redo the latest undo. If more than one undo has been done, you can redo 

them one at a time. The Redo function is also available as a button on the Tool Bar. 

Cut Allows you to cut the currently selected text from the help text while placing a copy of the 

text on the Clipboard. Text that has been cut can be pasted elsewhere in the help text using 

the Paste option. The Cut function is also available as a button on the Tool Bar. 

Copy Allows you to copy the currently selected text to the Clipboard. Text is normally copied to 

the Clipboard so that it can be pasted elsewhere in the help text using the Paste function. 

The Copy function is also available as a button on the Tool Bar. 

Paste Allows you to paste the contents of the Clipboard to the current location in the text. Text 

and images can be cut or copied to the Clipboard and these can then be pasted. This option 

is also available as a button on the Tool Bar. 

 

Note: The Clipboard used within the Help Editor is the standard Windows Clipboard. 

Thus, items placed on the Clipboard outside of the Help Editor can be pasted into the help 

text. For example, you can cut or copy a section of text from within Microsoft Word and 

then paste that text directly into the Help Editor. 

Select All Allows you to select all of the help text contents. 

Find Allows you to invoke a find of a specified phrase. When this option is selected, the Find 

screen is displayed. 

The Find screen enables you to specify a phrase that you would like to find in the text. You 

can also customize your search in regard to direction. The Match Case check box allows 

you to specify whether or not the search needs to be case sensitive. The Find option is also 

available as a button on the Tool Bar. 

Replace Allows you to replace a specified phrase with another phrase or a blank. When this option 

is selected, the Replace screen is displayed. 

The Replace screen enables you to specify a phrase you would like to replace with another 

phrase or a blank. The Match Case check box allows you to specify whether or not the 

search needs to be case sensitive. 

Insert Menu 

Picture Allows you to insert an image into the text at the current cursor position. When this option 

is selected, the Select File popup screen is displayed. Use the Select File popup screen to 

locate the desired image file. When a file is selected, the image will be returned to the 

editor at the location of the cursor. 

Table Menu 

Insert Table Allows you to insert a table at the current position. You are prompted for the number of rows 

and columns in the table. The table is inserted with captions. 
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Insert Row  Allows you to insert a row above the current position. This option is only available when in a 

table. 

Insert Column  Allows you to insert a column to the left of the current position. This option is only available 

when in a table. 

Delete Table Allows you to delete a table. This option is only available when in a table. 

Delete Row Allows you to delete the current row in a table. This option is only available when in a table. 

Delete Column Allows you to delete the current column in a table. This option is only available when in a 

table. 

Select Table Allows you to select the current table. This option is only available when in a table. 

Border Allows you to toggle the border on or off for the current table. This option is only available 

when in a table. 

Table Properties Allows you to update the properties for the current table. When this option is selected, the 

Table Properties screen is displayed  

The Table Properties screen allows you to specify the frame and color as well as the size and 

formatting for the current table. 

Show Gridlines Allows you to activate or deactivate the gridlines that are shown in the editor to indicate the 

row and column positions within a table. Gridlines are not borders and will not be visible 

when the document prints. 

Help Menu  
This menu contains options for the Help features within People-Trak.  

Help Topics Selecting the Help Topics option opens the Help Viewer. Help articles can be accessed via 

the three different tabs that are available on the left side of the screen. The Contents tab 

provides a tree-view of articles in a table of contents format, the Index tab provides a tree 

view of articles organized by the context in which they may be found. Search allows the user 

to enter a phrase or word and return all articles containing the phrase in the heading or article 

contents.  

 

The Help Topics feature is also available as a shortcut on the Shortcut Bar and on Help 

menus throughout People-Trak. 

Support Online  

 

Activates your browser and automatically attaches to the People-Trak customer support 

website. On the support website, you can download patches, review newsletters, provide 

feedback, and communicate with your Support Representative. The Support Online feature is 

also available on Help menus throughout People-Trak. 
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Help About Displays the Help About screen. The Help About screen displays details about your particular 

implementation of People-Trak including installation date, version, version date, number of 

records licensed, support expiration date; data file path and log file path. Additional product 

options are also listed and their associated check boxes are displayed as selected when they 

have been licensed. The Help About feature is also available on Help menus throughout 

People-Trak. 

Tool Bar 

Save  Saves the document and stays in the Text Editor. 

Spell Check  Launches the spell check utility. This utility is very similar to other spell checkers you have 

used in other word processing applications. It comes with its own dictionary to provide you 

with the most common words that are associated with common typos. 

Cut  Allows you to cut the currently selected text from the document while placing a copy of the 

text on the Clipboard. Text that has been cut can be pasted elsewhere in the document 

using the Paste option. The Cut function is also available as an option on the Edit menu. 

Copy  Allows you to copy the currently selected text to the Clipboard. Text is normally copied to 

the Clipboard so that it can be pasted elsewhere in the document using the Paste function. 

The Copy function is also available as an option on the Edit menu. 

Paste  Allows you to paste the contents of the Clipboard to the current location in the text. Text 

and images can be cut or copied from within the Explorer to the Clipboard and these can 

then be pasted. This option is also available as an option on the Edit menu. 

Note: The Clipboard used within the Help Editor is the standard Windows Clipboard. 

Thus, items placed on the Clipboard outside of the Help Editor can be pasted into the help. 

For example, you can cut or copy a section of text from within Microsoft Word and then 

paste that text directly into the Help Editor. 

Undo  Allows you to undo the latest action. The Undo function is also available as an option on 

the Edit menu.   

Redo  Allows you to redo the latest undo action. The Redo function is also available as an option 

on the Edit menu. 

Find  Allows you invoke a find the specified phrase. When this option is selected, the screen 

shown below is displayed. 

The Find screen enables you to specify a phrase that you would like to find in the text. You 

can customize your search in regard to direction. The Match Case check box allows you to 

specify whether or not the search needs to be case sensitive. The Find option is also 

available on the Edit menu. 

Insert Picture  Allows you to insert an image into the text at the current cursor position. When this option 

is selected, the Select File popup screen is displayed. Use the Select File popup screen to 

locate the desired image file. When a file is selected, the image will be returned to the 



Help Features 

 

 Help and Categories     9 

editor at the location of the cursor. Images can be moved and sized within the editor using 

the mouse. The Insert Picture option is also available on the Insert menu. 

Zoom Dropdown Allows you to zoom the contents of the editor to the desired zoom level. The contents can 

be zoomed from 10% to 400% of normal size. Zooming the contents of the editor does not 

affect printing of the document. The document will be sent to the Document Viewer at 

normal size. 

Topic  Name Displays the name of the topic being edited.  

Format Tool Bar 

The Format Tool Bar emulates many of the features in Microsoft Word. It allows you to 

quickly and easily edit fonts and font characteristics, as well as many other aspects of the 

document. 

Style Dropdown Allows you to change the style for the currently selected text. 

Font Dropdown Allows you to change the font for the currently selected text. 

Bold Allows you to set or unset the bold attribute for the currently selected text. This is a state 

button. If the button is in the down state, the text has already been set to bold. 

Italic Allows you to set or unset the italic attribute for the currently selected text. This is a state 

button. If the button is in the down state, the text has already been set to italic. 

Underline Allows you to set or unset the underline attribute for the currently selected text. This is a 

state button. If the button is in the down state, the text has already been set to underline. 

Left Justify Allows you to left justify the currently selected text. This is a state button. If the button is 

in the down state, the text has already been left-justified. This is the typical default setting 

when you begin your document. 

Center Justify Allows you to center justify the currently selected text. This is a state button. If the button 

is in the down state, the text has already been centered. 

Right Justify Allows you to right justify the currently selected text. This is a state button. If the button is 

in the down state, the text has already been right-justified. 

Full Justify Allows you to full justify the currently selected text. This is a state button. If the button is 

in the down state, the text has already been full-justified. 

Enumeration Allows you to activate or deactivate the numbering format for the currently selected text. 

This is a state button. If the button is in the down state, the text has already been set to the 

numbering format 
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Bullets Allows you to activate or deactivate the bullets format for the currently selected text. This 

is a state button. If the button is in the down state, the text has already been set to the 

bullets format. 

Indent Paragraph Indents the current paragraph. 

Outdent Paragraph Outdents the current paragraph. 

Highlight Color Allows you to choose the highlight color for the selected text. 

Text Color Allows you to choose the font color for the selected text. 

Ruler 

The Ruler is located between the Format Tool Bar and the text area. The Ruler is used to 

view and to modify indents and tab stops with the mouse. These same settings can be 

changed manually using the Paragraph option on the Format menu. 

First Line Indent

  

 

The first line indent is denoted by a small triangle on the upper half of the Ruler. First line 

indents can be either left (less than) or right (greater than) of the left margin. When a 

paragraph is indented on the first line, the first line indent is to the right of the left indent. 

When bullets or numbering are used, the first line indent is left of the left indent to 

accommodate the bullet or number symbol. 

Left Indent The left indent is denoted by a small triangle on the lower half of the Ruler. The left indent 

can be moved independently of the first line indent. 

Right Indent The right indent is denoted by a triangle on the right-hand side of the Ruler. 

Tabs Tabs are denoted by the appropriate tab symbol on the Ruler. Left-click on the ruler to add 

a left-justified tab or right-click to add a right-justified tab. You can also set tabs using the 

Tabs option on the Format menu. 

 Status Bar 

The Status Bar is used to display information about the current cursor position and the current 

edit status. 

 

Section Counter Displays the current section number for your cursor placement followed by the total 

number of sections in the document.  

Page Counter Displays the current page number for your cursor placement followed by the total number 

of pages in the document. This section of the Status Bar is only visible in Page Layout 

mode. 
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Line Counter Page Layout: Displays the current page line in relation to the current page your cursor is 

on. Therefore, as you page down, the Line Counter will start over at “1”. 

 

Draft: Displays the current line your cursor is on. There are no “pages” in this view, so the 

numbering just continues throughout the document. 

Column Counter Displays the current column of your cursor’s placement. 

Zoom Displays the current zoom percentage. 

Insert/Overstrike Displays the current status of the insert/overstrike mode. If insert mode is active, the 

section displays “INS”. If the overstrike mode is active, the section displays “OVR”. 

Caps Lock 

Indicator 

Displays the current status of the Caps Lock key. If Caps Lock is on, the phrase “CAPS” is 

displayed. Otherwise, the section is blank. 

Num Lock 

Indicator 

Displays the current status of the Num Lock key. If Num Lock is on, the phrase “NUM” is 

displayed. Otherwise, the section is blank. 

Working with Images 

Inserting an Image 
Placing images in the Text Editor is quite simple. Use the Insert Picture option on the Insert 

menu or the Insert Picture button on the Tool Bar to activate the Select File popup. Use the 

Select File popup to locate the desired image file. When a file is selected, the image will be 

returned to the editor at the location of the cursor. 

Moving and Sizing an Image 
Images can be moved and sized using the mouse. To move the image, simply click on the 

image and drag it to wherever you want. To size the image, click on the image and then click 

on any of the drag handles and drag in any direction. 

Deleting an Image 
An image can be deleted like any other character. Select the image by clicking on it. Then, 

press the DELETE key to delete the image. 

Working with Tables 

The Text Editor provides complete table support for creating grids that simulate the data 

entry screens showing rows and columns of data. 

Inserting a Table 
A table can be inserted at any point within a document, except within an existing table. To 

insert a table, use the Insert feature on the Table menu and select Table. The New Table 

Parameters screen is displayed. 
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This screen is used to specify the rows and columns for the table that you wish to create. You 

do not have to get the exact number correct because these can be adjusted later. However, it is 

useful to get the number close.  

When you have specified the rows and columns, the table will be inserted as shown in the 

example below. In this case, the table below was generated with two rows and two columns. 

 
 

Note that an additional caption row was added and that captions were inserted for you. This 

feature can speed the process of adding caption rows considerably. If you do not wish to have 

a caption row, use the Delete Cell option on the Table menu and then select Delete Rows to 

delete the caption row. 

Deleting a Table 
A table can be deleted at any time as long as there are no merge fields in any of the cells in 

the table. If there is text in the table, but no merge fields, the table can be deleted. To delete a 

table, select the table and then use the Delete Table option on the Table menu. 

Inserting and Deleting Rows 
Rows can be added to a table at any time. On the Table menu, select Insert Row Above or 

Insert Row Below option to indicate where the row is to be inserted. Rows can be inserted at 

any time whether or not text has been added to any of the cells.  

Rows can be deleted from a table at any time. On the Table menu, select Delete Row. If there 

is text in the row, it is deleted along with the row. If there are any merge fields in any of the 

cells in the row, the row cannot be deleted. You must delete merge fields individually from a 

row before the row can be deleted. 

Inserting and Deleting Columns 
Columns can be added to a table at any time. On the Table menu, select Insert Column to Left 

or Insert Column to Right option to indicate where the column is to be added. Columns can 

be inserted at any time whether or not text has been added to any of the cells. 

Columns can be deleted from a table at any time. On the Table menu, select Delete Column. 

If there is text in the column, it is deleted along with the column. If there are any merge fields 

in any of the cells in the column, the column cannot be deleted. You must delete merge fields 

individually from a column before the column can be deleted. 

Resizing Columns 
Columns can be resized using the mouse. Click the mouse on the desired column line and 

drag the column to the left or right as desired. You can drag columns to any desired position 

with or without text in the columns. 

Working with Cells 
Each cell is a distinct section of a document. You can add text and format text within a cell 

completely independently of the text and formatting within another cell, even if a cell is 

within the same row or column. You can use the mouse or the tab key to move the cursor 

between cells. 
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If the text of any cell on a row is wider than the space provided, the text will wrap and the 

row height for the entire row will be increased. One or more merge fields can be inserted into 

the cell as desired using the same techniques described in the section below. 

Setting Background Colors 
You can set the background color for the whole table or any part of it by highlighting all or 

part of the table and clicking the Background Color button on the Tool Bar. You can then 

select the appropriate color you want to apply. 

Mouse and Keyboard Functions 

Mouse Functions 

Click Moves the cursor to the point of the click or selects an existing field or image. 

SHIFT + Click Extends the selected text to the point of the click. 

Double-Click Selects the word that is clicked. 

Drag Selects the text from the point of the click to the place where the button is released. 

Double-Click 

Drag 

Extends the selected text from the first selected word to the place where the button is 

released. 

Keyboard 

HOME Moves the cursor to the beginning of the current line. 

END Moves the cursor to the end of the current line. 

LEFT ARROW Moves the cursor one character to the left. 

RIGHT ARROW Moves the cursor one character to the right. 

UP ARROW Moves the cursor up one line. 

DOWN ARROW Moves the cursor down one line. 

CTRL + LEFT 

ARROW 

Moves the cursor to the beginning of the current word. 

CTRL + RIGHT 

ARROW 

Moves the cursor to the beginning of the next word. 

CTRL + ENTER Inserts a new page. 
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SHIFT + ENTER Creates a line feed. 

DELETE Deletes the selected text. 

SHIFT + DELETE Copies selected text to the Clipboard and deletes the selected text. 

CTRL + INSERT Copies selected text to the Clipboard. 

SHIFT + INSERT Pastes the contents of the Clipboard to the current location in the text. 

CTRL + SHIFT+ 

SPACE 

Inserts a non-breaking space. 

CTRL + 

BACKSPACE 

Deletes the previous word. 
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This lesson gives you a tour of all of the help features available with People-Trak.  

Tutorials 
Help Topics: shows how to view the contents of the entire People-Trak documentation suite. 

Category Help: shows how to access category help. 

Field Help: shows how to access field help. 

Screen Help: demonstrates how to access screen help. 

Editing Help: shows how to add help for a document. 
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Tutorial 1.1 – Help Topics 

Help topics are available on any screen by using the Help Topics option on the Help menu. 

The Help Topics option allows you to view the contents of the entire People-Trak 

documentation suite.  

First, let’s look at how to pull up help topics from the Organizer desktop. 

1. On the Help menu, select Help Topics. 

The Help Viewer screen opens up with the Contents tab displayed. When selected, 

Contents tab shows a preloaded list of reference documents with the first document 

highlighted. Documents are displayed in a three level tree view organized first by 

document, chapters, and sections in each chapter. Let’s take a glance at the 

Administration Guide using this tab. 

2. Click the “+” sign adjacent to the Administration guide 

As you can see, the tree has expanded to show the chapter headings for the 

Administration document. Notice that these same chapter headings are also displayed in 

the area to the right. Now that we can see the chapters that this document contains, let’s 

take a closer look at one of them. 

3. Click the “+” sign adjacent to the Enterprise Setup chapter. 

This time, the tree has expanded to show the section headings for the Enterprise Setup 

chapter. The display area now shows our selected chapter and the section headings as 

well. 

4. Click the Introduction to Enterprise Setup section. 

The Introduction to Enterprise Setup article is displayed for you to read. Help articles are 

just clicks away! 

But say we forgot how to copy a record and that’s all we really want to read about. We 

don’t have time to browse through different guides and chapters. This is a situation where 

we can utilize the Index tab. 

5. Select the Index tab. 

Under the Index tab, contexts are listed alphabetically. Help articles can be viewed for a 

particular context by simply selecting it. 

6. Scroll down through the list of contexts and select Copying Records. 

The article is displayed in the right hand area of the screen for us to read and brush up on 

your record copying skills. 

7. Select the Search tab. 

The Search tab article results are blank when the Help Viewer is first opened. In order to 

search articles, all you have to do is enter the desired phrase or text in the search box and 

select the Go button. All articles containing the phrase in the heading or article contents 

will be returned to the Search pane in list format.  

We want to search for all articles that contain the phrase Module Setup. 
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8. Enter the search phrase Module Setup and select the Go button. 

Immediately, the applicable articles are listed. The first article is highlighted and ready to 

read. Select another article in the list that you would like to read. 

9. Select Close to close the Help Topics screen and return to the Organizer desktop. 

That’s a quick tour of the Help Topics feature of People-Trak. All of the documentation 

available with People-Trak is at your fingertips. Be sure to use this wealth of information. 

10. Continue with the next tutorial. 
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Tutorial 1.2 – Category Help 

The Category Help feature allows you to view help text for all activities, derived fields, 

documents, processes, screens, table maps, tables, templates, triggers and workflows within 

the current category. 

Let’s take a look at help for the Personal category in the Personnel Management module. 

1. Open Donald Stern’s record.  

 

Help within a category is accessed by clicking the Category Help button, which is the 

fourth button on the Category Bar. Category Help is available from virtually all of the 

primary data entry screens and sub screens in People-Trak. 

2. Click the Category Help button.  

The Help for Personal Category screen is displayed.  This screen is made up of two 

different components: a pane on the left and the help text display area on the right.  The 

pane on the left side of the screen utilizes a tree-view control with the activities, derived 

fields, documents, processes, screens, table maps, tables, templates, triggers and 

workflows nodes listed on the first level and the activities, derived fields, documents, 

processes, screens, table maps, tables, templates, triggers and workflows listed by name 

at the second level.  

We are going to take a look at documents first. 

3. Highlight the Documents node and click the “+” sign. 

The node expands to list the names of the documents assigned to the Personal category.  

To learn more about a particular document, all we need to do is select it. 

4. Highlight the Alphabetic Employee List.  

In the viewing area to the right, you will see that the help text is displayed and ready for 

you to read. That’s all there is to it. 

How about we learn more about one of the templates in this category? 

5. Highlight the Templates node and click the “+” sign. 

6. Highlight the Welcome Letter.  

Review the help text and soak up the knowledge that Category Help has to offer. 

7. Close the Help for Personal Category screen and remain in Donald’s record. We still 

have more help features to explore. 

8. Continue with the next tutorial. 
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Tutorial 1.3 – Screen Help  

Screen help is accessible from any screen. Since we are already on the Personal screen, we 

can take the opportunity to learn more about it. 

1. Press SHIFT + F1. (Hold down the SHIFT key while pressing the F1 key.) 

 

The Screen Name: Personal screen is displayed.  

This screen is made up of two different components: a pane on the left and the help text 

display area on the right.  The pane on the left side of the screen utilizes a tree-view 

control with the overview, screen objects, and usage listed at the first level. We will take 

a closer look at the other levels for screen objects in just a moment. 

But before we do that, screen help has provided a great amount of information about the 

Personal screen and a few of its features in the overview.  

Take a minute to read and scroll through the help text and learn something new. With that 

accomplished, we can focus on the screen objects that the Personal screen contains. 

2. Highlight the Screen Objects node and click the “+” sign. 

The node expands to list the objects found on the Personal screen. 

3. Highlight the Address Frame node and click the “+” sign. 

The node expands to show the fields found within the Address frame. 

4. Select the Address 2 field to display the help text for the field. 

5. Close the Screen Name: Personal screen by selecting the Close or X button. 

 

There is one more way of accessing screen help.  

6. On the Tool Bar, click the Show Screen Help button. 

Once again, the Screen Name: Personal screen is displayed.  

7. Close the Screen Name: Personal screen and stay in Donald’s record.  

8. Continue with the next tutorial 
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Tutorial 1.4 – Field Help 

Field help is available at any field. Let’s look at a field on the Personal screen to see how this 

works. 

1. You should still be on the Personal screen. 

2. In the Last Name field, press F1. 

The Field Name: Last Name screen is displayed and just like we saw in screen help, an 

overview is ready to read. 

This screen is made up of two different components: a pane on the left and the help text 

display area on the right.  The pane on the left side of the screen utilizes a tree-view 

control with the overview and usage listed at the first level.  

For now, let’s take a look at where the Last Name field is being used. 

3. Highlight the Usage node and click the “+” sign. 

The node expands to list field usage areas. 

4. Highlight the Derived Fields node and click the “+” sign. 

The node expands to show the derived fields that use the Address 1 field. 

5. Select the Address Block derived field to display the help text. 

In addition to an overview and usage, field help provides information about the properties 

and attributes associated with the field. We will be taking a more detailed look at 

properties and attributes and how usage is updated in Essential Tools training. 

6. Close the Field Name: Last Name screen by selecting the Close or X button. 

 

Now for another way to look at field help. 

7. On the Tool Bar, click the Show Field Help button. 

 

Once again the same help screen is displayed. 

8. Close the Field Name: Enterprise Name screen. 

9. Click in any other field on the Personal screen and use one of the two methods to pull up 

field help for that field. 

 

Field help is displayed, except this time the information is for the field you chose. 

10.  Close the Personal screen. 

11. Continue with the next tutorial. 
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Tutorial 1.5 – Editing Help 

As you have seen throughout the help features, many of the documents within People-Trak 

have been assigned help. This help provides a basic description of the document and what it 

is used for. This help can be activated in one of two ways. You can view the help text for the 

document in Category Help or by selecting the Help button in Document Properties. We will 

be using the latter method to edit help for an existing report. 

Note: The ability to edit help can be turned off for a user by clearing the Allow Help Edit 

check box in Security Setup. 

1. On the Documents menu, select Adhoc Reports.  

2. Select the General category to display a list of documents.  

3. Highlight Average Age by Department report in the list but do not open it.  

4. On the File menu, select Adhoc Report Properties or on the Tool Bar, click the Adhoc 

Report Properties button to display the properties for this document. 

5. Click the Help button to display the help text for this document.  

The help text for this document is blank, so let’s add some to help out other users. 

6. Select the Edit button. 

The Help Editor is displayed. 

7. Enter the following text: 

This document is used to calculate the average age of employees by gender.  
 

Remember, from this point forward, this is the text your users will see when they seek 

help for this document. Your users are counting on you.  

8. Close the Help Editor and save your changes 

9. Close all subsequent screens and return to the Organizer desktop. 

 

It’s time to see our help text in action. 

10. Open Donald Stern’s record. 

11. On the Personal screen, select the Category Help button.  

12. Highlight the Documents node and click the “+” sign. 

13. Highlight the Average Age by Department document.  

Voila! The edited help text is displayed for all to see.  

14. Close the Help for Personal Category screen. 

15. Close Donald’s record.  

16. Exit People-Trak. This concludes this tutorial and lesson. 


